Menu

1 juni 2010

iPad touchscreen niet meer accuraat (na jailbreak)

Wanneer je iPad is voorzien van de spirit jailbreak dan kan het voorkomen dat het touchscreen iets minder accuraat werkt dan voordat de jailbreak was uitgevoerd. Met name het tappen op kleinere knoppen in de interface gaat minder soepel, je dient in de meeste gevallen onderaan de knoppen te tappen.

Het probleem ontstaat na het uitvoeren van het jailbreak proces, waarschijnlijk wordt er bij het jailbreaken een dynamische library (dylib) geïnstalleerd die nog niet volledig compatible is met de iPad. Dit probleem zal vast en zeker in een volgende versie van het jailbreak proces worden verholpen.

Gelukkig is er tot dat moment een oplossing om het scherm 100% accuraat te laten werken, hiervoor kan je gebruik maken van het Cydia package “SBSettings”. Dit package heeft de mogelijkheid om een respring van je Springboard uit te voeren, na een respring functioneert het touchscreen weer accuraat. Dit blijft zo totdat de iPad wordt herstart, hierna dien je opnieuw een respring uit te voeren.

Het is ook mogelijk om het Springboard te herstarten met behulp van een SSH verbinding. Nadat je bent ingelogd typ je het commando:

killall SpringBoard




Gerelateerde tips:




Reacties


  • Wess 1 juni 2010 om 18:27

    Zo zie je maar dat al dat Jailbreaken meer “kwaad” dan goed doet..
    Even tanden bijten en in de herfst hebben we een aangepaste OS4 op onze iPad..
    Nice!

  • Jorn 1 juni 2010 om 19:42

    Welk SBSettings thema gebruik je?
    Ziet er wel nice uit!d

  • T. 1 juni 2010 om 22:44

    Mijn iPad zit er vaak vanzelf al naast, vooral edit-velden waar de inhoud/invoer er als een soort ghost half onderhangt. Geen jailbreak voor nodig ;-)

    Mijn 2g doet al jaren de jailhouse rock,
    maar kan iemand mij het nut van jailbreaken op de iPad uitleggen?
    (afgezien van klootviolen in je filesystem, ssh)
    Zijn er killer iPad apps in Cydia?

  • MarcoS 2 juni 2010 om 0:51

    Was mij ook al opgevallen, maar pas dit weekend na installatie van WiFi Sync. Heb toen uit automatisme een respring uitgevoerd en toen was het weer normaal. Nu weet ik waarom en dat ik dit na een herstart opnieuw moet doen. Thnx Richard

  • Alger 3 juni 2010 om 17:35

    Ik dacht al dat het aan mij lag, misschien te dikke vingers ofzo. Respring in SBSettings werkt perfect. Bedankt voor de tip. Nu nog aan de slag met de locatie bepaling.

  • Jurgen 3 juni 2010 om 21:59

    @Jorn: Dit is het gebruikte theme voor SBSettings:

    http://macristocracy.com/vanilla/comments.php?DiscussionID=400&page=1#Item_0

Een reactie toevoegen: