Menu

1 juni 2010

iPhone wordt niet herkend door iPhoto & Aperture

Sinds enkele weken had ik last van een hardnekkig iPhone probleem. Zowel iPhoto, Aperture als Fotolader detecteerde mijn iPhone 3GS niet meer. Al zoekende op Google kwam ik er snel achter dat ik niet de enige was met dit probleem.

Op het internet worden meerdere ‘oplossingen’ beschreven voor dit probleem maar geen van deze oplossingen zorgde ervoor dat mijn iPhone weer gedetecteerd werd door de applicaties. Toch heb ik uiteindelijk een verassende oplossing gevonden.

Door middel van een SSH verbinding naar mijn iPhone heb ik de naam van de map ‘DCIM’ waarin de foto’s worden opgeslagen gewijzigd. Deze map wordt automatisch door de iPhone weer aangemaakt en spontaan werd mijn iPhone weer herkend, dit betekent dus dat het probleem werd veroorzaakt door de fotomap.

Natuurlijk ben ik dan wel heel erg nieuwsgierig waar het precies fout gaat. De foto’s worden per 100 in een map geplaatst binnen de bovenstaande map. Nadat ik de eerste 200 foto’s had teruggeplaatst werkte alles nog perfect, na het terug plaatsen van de volgende 100 ging het echter weer mis. Het grote verschil tussen de laatste map met 100 foto’s en de eerste 200 was dat er een plaatje tussen zat dat ik via Mobile Safari had toegevoegd aan de filmrol. Door deze afbeelding te verwijderen met behulp van de standaard Foto’s applicatie op iPhone werd ook spontaan mijn iPhone weer herkend.

Hoe vreemd het dus ook klinkt, als je iPhone niet meer wordt herkend door iPhoto, Aperture of Fotolader verwijder dan alle afbeeldingen uit de Filmrol die zijn bewaard met een andere applicatie dan de standaard camera applicatie. Begin daarbij met de afbeeldingen die met behulp van Safari op de filmrol zijn geplaatst, en de meeste gevallen is dit de veroorzaker van de problemen.




Gerelateerde tips:




Reacties


  • Roel 1 juni 2010 om 10:31

    Ik liep tegen precies hetzelfde probleem aan. Na wat googlen kwam ik erachter dat de foto-applicaties m’n iPhone niet meer herkenden omdat ik vanuit de iPhone e-mail app foto’s in mijn fotorol had opgeslagen. Zie ook: http://discussions.apple.com/message.jspa?messageID=10223733#10223733

    Maar nu zal ik ook voorzichtiger zijn met beelden opgeslagen vanuit Mobile Safari.

  • iPhone 4G 1 juni 2010 om 11:06

    Ik heb helaas precies hetzelfde probleem

  • HCHybrid 1 juni 2010 om 12:35

    Ik heb een andere oplossing qua iPhone herkenning binnen zowel fotolader als iTunes op m’n MPB 13″ van dec. 2009… 1e USB slot geen herkenning… 2e USB slot WEL herkenning… asjemenou?! Eén ding scheelt… m’n MBP is hier wel consequent in ;-)
    Hebben jullie dit ook al geprobeerd toevallig?

  • Frank 1 juni 2010 om 14:18

    Het moet inderdaad aan de foto’s of filmpjes liggen die je op de iphone opslaat. Ik synchroniseer 2 iphones op 1 macbook en heb maar met 1 toestel problemen. De ander start altijd automatisch iphoto en itunes op de anders alleen itunes

    Succes

  • Mischa van Schaijk 14 augustus 2010 om 14:10

    Ik had hetzelfde probleem.

    Via Cydia mijn OpenSSH gestart en via de terminal (iMac) naar mijn telefoon ge-ssh-ed.

    In de /User/Media stond de DCIM dir met daarin 100APPLE en 101APPLE. Een van de dirs zorgde voor het feit dat ik de iphone niet in iPhoto zag.

    de folder 101APPLE even van naam veranderd en voila! (met mv -f -r).

    Goede tip dus!

  • sjoerd 21 augustus 2010 om 20:44

    Bij mij zelfde probleem. Oorzaak: een paar foto’s die ik vanuit Iphone Mail opgeslagen heb in Filmrol. Na verwijderen was het probleem direct verholpen.

  • Anna 12 oktober 2010 om 16:00

    Ah, ik had hetzelfde probleem, wat toen opeens weer opgelost was, maar ik had niet zo goed door hoe ik het opgelost had. Dit verklaart een heleboel. :-)

  • marijne 9 augustus 2014 om 16:25

    Hoi,
    Ik heb hetzelfde probleem, maar ik heb dus 13.000 foto’s en het duurt waarschijnlijk uren om die allemaal te checken.. Iemand nog een andere oplossing?

Een reactie toevoegen: