Menu

16 januari 2009

Leopard installeren op een G4 (< 867mhz)

g4-processor

De eigenaren van oudere Macs kunnen tegen het probleem aanlopen dat Leopard niet wilt installeren aangezien deze niet voldoet aan de minimale systeem eisen. De processor snelheid dient minimaal 867mhz te zijn en de Mac dient minimaal 512Mb intern RAM geheugen te hebben. Het geheugen probleem is natuurlijk eenvoudig op te lossen door extra geheugen te plaatsen. Een processor vervangen is minder eenvoudig en in sommige gevallen zelfs niet mogelijk.

Doormiddel van Leopard Assist een kleine gratis tool gemaakt door GenThree software wordt het mogelijk om ook op tragere Mac’s als nog Leopard te installeren.

Leopard Assist voert een script uit dat een aanpassing in het “Parameter RAM” (PRAM) maakt waardoor Leopard denkt dat de Mac een processor bezit van 867mhz (de minimale eis). Hierna kun je de Leopard installatie starten zonder dat deze aangeeft dat de hardware eisen niet toereikend zijn. Na de installatie wordt het PRAM geheugen automatisch weer hersteld door Leopard naar de originele waardes er vinden dan geen hardware checks meer plaats.

Het spreekt voor zichzelf dat je natuurlijk niet te veel moet verwachten van de prestaties van Leopard op een oudere/tragere Mac. Zie de tip: Finder vloeiender op een ‘oude’ Mac om in iedergeval Finder iets soepeler te laten werken.

Let op dat niet alle oude Mac’s worden ondersteund, voor een actueel overzicht en download pagina: http://mac.profusehost.net/leopardassist/index.html

De truc die Leopard Assist uitvoert kan je overigens ook handmatig uitvoeren in open firmware mode, voor de echte Mac die-hards:

Voor een single CPU systeem gebruik je dan:

dev /cpus/PowerPC,G4@0
d# 867000000 encode-int " clock-frequency" property
boot cd:,\\:tbxi

Dual CPU:

dev /cpus/PowerPC,G4@0
d# 867000000 encode-int " clock-frequency" property
dev /cpus/PowerPC,G4@1
d# 867000000 encode-int " clock-frequency" property
boot cd:,\\:tbxi




Gerelateerde tips:




Reacties


  • AJ 16 januari 2009 om 13:45

    Dit is wel een heeeeel oude tweak,
    ik heb hem vroeger zelf nog gebruikt ;)

  • KM 8 maart 2009 om 12:01

    Hoe kan ik Leopard installeren op mijn macbook waar tiger op staat volgens de systeemvereisten moet ik minimaal 867 Mhz hebben maar ik heb maar 667 Mhz hoe kan ik dit veranderen door middel van een programma zoals hierboven genoemd, het programma van hierboven werkt niet met mijn computer, het programma zegt dan dat mijn computer geschikt is voor Leopard

  • rennified 9 april 2009 om 11:42

    Oeh,

    Ik heb het gewoon op m’n oude iBook geinstalleerd met een FW kabel en Target mode. Op een veel snellere (G4) Mac Mini heb ik Leopard via FW op de HD van de iBook gezet. Na de installatie en een reboot werkt alles eigenlijk best als een zonnetje :-)

Een reactie toevoegen: